Issue with SSL certificate

Incident Report for integrator.io

Resolved

Our SSL certificate for the domain integrator.io (in the US region) got expired.
Posted May 17, 2023 - 17:00 PDT